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Introduction  

1. Introduction 
This document gives practical recommendations for creating both interactive 3D visualization of complex 
technical procedures and 3D visual training, by reusing existing 3D CAD and Product Data Management 
(PDM) data.  

A document containing a 3D procedure is a collection of one or more groups of textual information, called a 
procedure step, and each step is associated with a 3D visualization.  

A training document is an application that contains the training tasks and 3D visualizations assigned by the 
author for the trainee. The training can run standalone or within the Learning Management System (LMS).  

The RapidManual and RapidLearning Packages consist of the following applications: 

Virtual Manual Editor (VME) (RapidManual Only) is a powerful authoring application for building interactive 
animated 3D procedures for technical support, maintenance and operations. This application provides both a 
visually oriented approach and a natural language based interface that allows people with little or no 
experience in 3D to rapidly build comprehensive 3D procedures. Published content can be delivered as 
standalone solutions or to integrate them into existing PLM, IETM or CRM systems. 

Virtual Training Editor (VTE) (RapidLearning Only) is an expanded version of VME. In addition to the VME 
functionality, VTE also offers the user the ability to create SCORM-compliant multi-mode training applications 
by combining 3D procedures with existing training materials. Created training applications can be used 
standalone or integrated into existing LMS systems. 

Virtual Manual Generator (VMG) is an application used to import 3D models of devices and equipment 
exported from CAD-like systems. To import 3D graphics data, VMG uses a set of customizable components 
(plug-ins) designed for different CAD systems.  

Virtual Manual Administrator (VMA) is an application, which provides you with advanced abilities to 
manage projects and working folders for all the RapidProduct applications.  

 

2. Process Layout and Basic Operations 
The process of digital documents creation involves six basic steps: 

• Preparing input data. 3D data and additional PDM data for the procedure is obtained from CAD-like 
system. 

• Input data is imported into a new project using VMG. 

• Editing imported 3D data in the project.   

• Creating 3D procedure.  

• Creating training procedure that is based on the 3D procedure (only in VTE).  

• Publishing the project. Using VME or VTE, the author publishes to get the final 3D procedure and/or 
training. 
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Fig.1. General work flow diagram. Box – an application; parallelogram – data. Dimmed figures – input and 
output data used in the development process. 

2.1. Preparing Input Data 

The following set of input data is required for creation of 3D procedure and training: 

1. 3D graphics data in either VRML or JT file format. 

2. Additional procedure document can be used for automatic generation of procedure and training 
scenario templates, for example S1000D procedural data modules. 

2.2. Adding Data to Project 

A project can be created and filled in with 3D graphics data using the following basic steps: 

1. Creating a working area.  

2. Creating a project. 

3. Adding data to a project. 

All of these steps are performed in the VMG application. To start VMG, choose Start > Programs > 
ParallelGraphics > Virtual Manual Generator > Virtual Manual Generator. 
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Process Layout and Basic Operations  

A project stores information about 3D graphics and other related data. A working area (or configuration) is a 
specially organized set of working folders that contain one or more projects and their published output. 
Configurations can be accessed in all of the RapidManual/RapidLearning applications.  

In the working area the author creates a new project and fills it with the input data.  

Procedure 

1. To create a working area: 

• In VMG, from the Tools menu, choose Select Configuration.                                                           
The Select Configuration dialog box appears.  

• In the Select Configuration dialog box, click New.                                                                             
The New Configuration dialog box appears. 

• In the Configuration box, type a descriptive name of new configuration. In the Description box, type 
a text describing the new configuration (working area) in more detail. Click OK. 

  

• The new configuration appears selected in the Select Configuration dialog box. Click OK to enable 
VMG to use the specified working area. 

 The working area is created in the following folder:  
 <System Disc>:\Documents and Settings\All Users\ Application Data\ParallelGraphics\VM 

NOTE: Virtual Manual Administrator (VMA) provides advanced abilities to manage working folders including 
working folders on local server that is available to several users. For more information about this, see VMA 
help system. 

2. To create a new project: 

• On the File menu, click New Project.                                                                                                              
The New Project dialog box appears. 

• In the Project Name box, type the descriptive name for the project, and then click OK.                         
This creates a new empty (that is, without any geometry data) project in the current working area.   
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Process Layout and Basic Operations  

  

3. To import input data to the project: 

• Choose the required plug-in by clicking its name in the list of available plug-ins in the Plug-in name 
box.  

• If required, specify the optimization parameters and settings for importing. To do this, on the Tools 
menu, click Options. Please note that it is recommended to use the default settings. For more 
information about settings, see VMG help system. 

• If required, specify the settings for the selected plug-in. To do this, click Settings. Please note that it is 
recommended to use the default settings. For more information about plug-in settings, click the Help 
button in the currently open dialog box. 

• To start importing the input data, click Start. 

• In the Select main VRML file dialog box, select the supported geometry file to be imported, and then 
click Open. 

  

• The length of time for import procedure depends on the amount of input data. If the default settings for 
importing have been specified, VMG saves the project in the end of the importing procedure. 
Otherwise, on the File menu, click Save. 
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3. Working with Project in VME or VTE 
A project is edited using the VME or VTE application. To start it, click Start > Programs > ParallelGraphics 
and then finally choose Virtual Manual Editor or Virtual Training Editor. 

Before getting started, it is important to become familiar with the application components and screen layout. 
This knowledge will help the author move freely and smoothly throughout the system. 

 

 

Fig.2. The VTE Screen Layout: overview. 

 

Scene Tree window 

The Scene Tree window is used for viewing, selecting, changing the scene tree hierarchy and deleting parts 
from the 3D scene. Common Scene Tree commands can be accessed from the right-click menu.  
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Working with Project in VME or VTE  

Scene List window 

The Scene List window displays the current set of parts and allows the parts list to be sorted. Commands are 
similar to those in the Scene Tree window.  

2D Preview window 

The 2D Preview window renders an outline of the current view displayed in the 3D View window. The window 
is used for preparing and previewing a view that can be exported as a 2D CGM image. There are two types 
of image projection available for the 2D Preview window; orthographic and perspective.  

Parts List window (only in VTE) 

The Parts List window displays the current set of parts and their metadata that can be selected by the trainee 
in the published training and allows the parts list to be sorted. Parts used in the training scenario are 
automatically added to the Parts List. Using the context-sensitive commands, the author can add parts not 
used in the training scenario and add or edit the part viewpoints.  

3D View window 

The readymade 3D procedure is viewed in the 3D View window. You can navigate the camera using the 
mouse or keyboard and specify a navigation mode with the Navigation bar. ParallelGraphics’ Cortona3D 
Viewer is used in this window. Some Cortona properties can be accessed by using the Options > 3D View 
command from the Tools menu.  

Procedure Editor 

Procedure Editor is used for viewing, selecting, creating, grouping and editing actions.  

Scenario Editor (only in VTE) 

Scenario Editor is used for creating training scenario.  

Main menu bar 

The menu bar, located directly under the VME/VTE title bar, provides access to the main menus for 
VME/VTE. The title of each menu indicates the purpose of the commands on the menu. Each menu uses 
standard Microsoft Windows conventions. Some commands are duplicated on several toolbars to enhance 
productivity and speed workflow.  

Standard toolbar 

Contains buttons for managing projects, modifications in the Scene Tree, choosing representations for the 
parts, and editing materials.  

Simulation toolbar 

Controls for 3D procedure: refreshing, VCR commands, displaying or hiding interface elements of the 3D 
procedure in the 3D View window.  

View toolbar 

Lets you show or hide each of the parts in the 3D View window. It contains buttons for highlighting in the 3D 
View window the parts corresponding the selected scene tree items, displaying the local coordinate axes, 
and controlling the camera.  

Navigation toolbar 

Located on the left of the 3D View Editor screen, the navigation toolbar contains buttons for controlling the 
navigation mode of the 3D View window of VME/VTE.  
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Procedure toolbar 

Contains buttons for creating, editing, modification and grouping actions, changing their tree hierarchy in the 
Procedure Editor window, and changing parameters of the Action and Timeline sections.  

Status bar 

Located at the bottom of the VME/VTE screen, the status bar displays informational messages about menu 
items, tool buttons, and actions performed in VTE. In the lower right corner, the status bar displays the 
current fraction for 3D procedure, and the identifier for the currently activated warning message.  

Flyouts 

There are also flyouts that may have additional commands in the sub-menu. A flyout is an icon-based menu 

available from any button that has a small black triangle in the lower-right corner, for example . To access 
the flyout, click and hold the button. Then to activate a flyout menu item, drag to the item and release.  

3.1. Opening a Project  

Once a project has been created using VMG, it can be opened in VME or VTE. 

Procedure 

To open a project: 

• Choose the same configuration that was specified in VMG for the project. To do this, click Tools, point 
to Options and click Select Configuration. In the Select Configuration dialog box, choose the name 
of configuration by clicking its name in the list. Click OK.  

• On the File menu, click Open Project. In the Open Project dialog box, click the name of required 
project, and then click OK. 

 NOTE: If the specification component of the project is not specified, the Select Specification dialog box 
 appears. This allows choosing a specification component for the project. See section 6.1 for more 
 information about choosing a specification. 

• When 3D data is imported into a project, it is initially hidden in the 3D window. To display the hidden 
items, select them in the Item Tree and make the items visible by using the Show Solid command (on 
the View menu, point to Hide/Show Selection, and then click Show Solid). 

• Use the Save Project command from the File menu to save your work. 

3.2. Selecting 3D Items  

Once you’ve got some objects in your scene, you can start putting them where you want them, choosing their 
level of detail and material, and changing their position in the scene hierarchy. All manipulations with 3D 
items can be done by applying commands to selected 3D items. There are several techniques for selecting 
3D items using different selection modes described below. 

3.2.1. Selecting 3D Items in Item Tree/Item List 

Procedure 

To select item(s) in the Item Scene Tree/Scene List: 

• Click the item name or icon. The name of the selected item is highlighted.  
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• To select multiple items, click the items one by one with the CTRL key pressed.  

• To select a group of items that are next to each other, click the first item, and then click the last item 
while pressing the SHIFT key.  

• To select items by a selection rectangle drawn in the Scene Tree/Scene List window, click somewhere 
in the Item Tree window and drag to pull out a selection rectangle. Continue dragging until the 
rectangle encloses all required items.  

3.2.2. Selecting Items in 3D Window 

Enabling the  Selection in 3D mode allows the selection of 3D items directly in 3D window. To do this, on 
the Selection menu, click Selection in 3D. 

There are two ways for selecting 3D items in 3D window: clicking 3D item in the 3D window, or drawing a 
selection rectangle (the Frame Selection mode).  

The Frame Selection Mode provides two selection options: Frame Crossing or Frame Bounding. 

•  Frame Crossing selects those 3D items that are partially contained by the rectangle drawn in the 
3D window. 

•  Frame Bounding selects those 3D items that are completely contained by the rectangle drawn in 
the 3D window.  

The  Assembly Selection in 3D mode allows the parent assembly of an item to be selected in the 3D 
window. To enable the mode, on the Selection menu, click Assembly Selection in 3D. 

The  Step-by-Step Selection in 3D mode allows the parent item to be selected by clicking its child item 
in the 3D window. Each successive click will select the parent item of the current selection, progressing up 
the hierarchy in Item Tree. When the last parent item of the hierarchy is achieved, the selection returns to the 
item initially selected in the 3D window. To enable the mode, click Step-by-Step Selection in 3D on the 
Selection menu. 

When the SHIFT, CTRL, or ALT key is pressed simultaneously with selecting items, 

CTRL – adds to the selection, 

ALT – subtracts from the selection, 

SHIFT – if in the Frame Selection mode, selects from the already selected.  

Procedure 

To select a 3D item in the 3D window: 

• Click the required 3D item in the 3D window. This highlights the item if the Highlight Selection button 
is pressed.  

To select multiple 3D items in the 3D View window: 

• Press and hold down CTRL, and then click each required 3D item in the 3D window you want to 
select.  
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To select 3D items by a selection rectangle:  

1. Choose one of the available selection options – Frame Crossing or Frame Bounding by choosing the 
corresponding command from the Selection menu. 

2. Click and drag anywhere in the 3D window to pull out a selection rectangle. Continue dragging until the 
rectangle encloses all the items to be selected. Be sure to start dragging at a point that will enclose the 
items required within a rectangle drawn from that point. Release the mouse button. The items that fall 
inside the selection rectangle appear highlighted.  

3.3. Setting a Scene 

After a 3D assembly has been imported into a project, it may need some modification to better suit the 
procedure. This includes deleting irrelevant 3D items, adding supplementary 3D items, moving objects, 
changing the scene hierarchy and changing the representation (level of detail) of 3D items. The Scene in the 
application contains all 3D items of the project.  

Procedure 

To delete a 3D item: 

1. Select the 3D item(s) to be deleted in the Scene Tree, Scene List or 3D View windows.  

2. On the Edit menu, click Delete. The deleted item can be restored.  

To reorder a 3D item within the scene hierarchy, do one of the following: 

• Right-click the item in the Scene Tree or Scene List window, click Change Parent, and then click a 
new parent name.  

• Just drag an item in the Scene Tree to a new place. 

To move or rotate an object in the scene: 

1. Select 3D item you want to move or rotate.  

2. On the Edit menu, click Set Position.  

3. Specify translation and rotation with the manipulator and commands from the Edit Position dialog box.  

To choose representation for a 3D item: 

• Select the 3D item(s) to be changed.  

• On the Edit menu, click Choose Representations by Weight or Choose Representation by Name.  

• In the corresponding dialog box, choose the required level of details, and then click OK. 

The application provides miscellaneous means of editing objects in the 3D scene. This includes material 
editing, trimming, merging shapes. See VME/VTE help system for other operations on editing 3D Scene 
(topic: Editing 3D Scene). 

3.4. Enhancing a Scene 

In addition to imported 3D data, objects from the Object gallery can be used to add special objects such as 
text labels, dimension lines, hoses, labels, callouts, ropes, tighten labels, and optionally user specified 3D 
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Creating 3D procedure  

models. These objects can be part of your 3D procedure and used in the procedure similar to imported 3D 
objects.  

When you add the object to the scene, a dialog box appears that allows you to specify its required 
parameters. The added object appears in the Scene Tree and Scene List windows and can be modified later 
on with the Edit Object Parameters context-sensitive command. 

Procedure 

To add an object from the Object gallery: 

1. On the File menu click Add Item from Object Gallery.  

2. Choose the object category by clicking the corresponding tab.  

3. Choose one of the objects by clicking its icon and then click Add. 

To edit objects that that have been added from the Object gallery: 

1. Right-click the object in the Scene Tree or Scene List window and choose Edit Object Parameters.  

2. Specify new parameters in the dialog box that appears, click OK.  

See VME/VTE help system for other operations with gallery objects (section: Object Gallery). 

4. Creating 3D procedure 
A 3D procedure can be created both in VME and VTE. Please note that when opening a project for the first 
time the author should determine the information standard (specification) of the 3D procedure document. If 
an S1000D document is required, select S1000D Issue 2.3 Procedure in the Select Specification dialog. This 
allows you to attach an S1000D data module and automatically create the structure of procedure in the 
Procedure Editor. If you are uncertain about the specification, choose Generic Procedure. This allows you to 
create the 3D procedure from the scratch.  

4.1. Creating Animations and Actions  

When creating a procedure, the author uses a set of predefined actions based on Simplified Technical 
English. An action is an operation associated with any object and actions are the building blocks of a 
procedure. Actions are shown in the Procedure Editor and can be grouped into steps or subtasks to suit the 
structure of technical procedure.  

By default, actions are executed sequentially. If you want to play several actions simultaneously, you have to 
group these actions under an action union. An action union is a special grouping item that is used to unite 
actions for their simultaneous playback and can contain other action unions and actions. 

Procedure 

To create an action: 

1. Choose an existing group (by clicking it) or create a new grouping item (click New Group on the 
Procedure toolbar) in the Procedure window. All actions must be part of a group.  

2. Select the item you want to create the action for.   

3. Create an action by clicking New Action on the Procedure toolbar and selecting the action name in 
the New Action dialog. Please note that although it is possible to form new custom actions, we 
recommend you use actions without changing their internal structure of commands (atoms and 
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functions). For more details about creating animations, see Basics of Creating Actions in the VME 
Help system. 

To view an action: 

1. To view the animation, play it in 3D View. Before playing, click the  Refresh button (the Simulation 
menu). It is necessary to play procedure correctly. 

2. Use the  buttons on the Simulation toolbar to control the playback of the 3D 
procedure.  

4.2. Editing Actions 

Actions applied to an item use default parameters. If the action does not appear correct when viewed, it can 
be edited and corrected. This can be done by changing fields of actions. A field is a data element that is 
contained in any action and can be edited by the author. A field has a name and a value of a particular type. 
The changeable part of a field is underlined. 

Procedure 

To edit an action: 

1. Expand the action in the Procedure Editor.  

2. Click the changeable part of a field that is underlined. Simple fields are edited by typing a new value. 
The others open the dialog box where you can change parameters with miscellaneous controls.  

See VME/VTE help system for other information on editing Actions (topic: Editing Actions). 

4.3. Making a Structure of the 3D Procedure 

Actions shown in the Procedure Editor should be grouped depending of the document structure of technical 
procedure. The author creates grouping items in the Procedure Editor. There are two different ways to create 
structure of the 3D procedure. The first way is to create groups from the scratch. The Procedure Editor 
provides quick, easy, and efficient means of creating and changing structure of the 3D procedure.  

The second way is to generate a structure on the basis of already existing document (XML file format) that 
describes a technical procedure. The file standard in this case should correspond to the specification chosen 
when creating the project. For example, if you have created a project according to S1000D Issue 2.3 
Procedure, the input document of technical procedure should follow the S1000D 2.3 standard.  

Each group may have procedure comments. Comments are normally used as a text description of the steps 
and sub-steps, and for generating the published 3D procedure document. 

Once you have a clear understanding of the 3D procedure steps, begin with making a structure and only then 
add animations.  

 

Procedure 

To create a new grouping Item: 

1. In the Action section of the Procedure Editor, click the item you want to create a grouping item for. 

2. On the Procedure Editor toolbar, click  New Group.  
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3. In the Edit Group dialog box that appears, enter the descriptive name of the grouping item in the 
Description box, choose the hierarchy level for a new grouping item in the Child of box and then click 
OK.  

 

To show or hide comments: 

• Click the  Comments button on the Procedure toolbar.  

Adding comments: 

• Click in a blank area to the right of the task, subtask or action, and then type a comment.  

To attach a document to a project: 

1. On the Edit menu, click Attach Document. 
The Attach Document dialog box appears.  

2. In the Attach Document dialog box, select a document file to be attached, and then click Open. 
The Document window appears.  

See VME/VTE help system for other information on making a structure of 3D procedure (sections: Basics of 
Creating Actions, Working with Documents). 

4.4. Creating a 2D Image 

The VME and VTE applications allow the author to generate outline images of the view in the 3D window. 
These images can be edited and stored within a project. 

To create an outline image for a project: 

• Click the 2D Preview tab to make the 2D Preview window active. 

  

The 2D Preview window renders an outline of the current view displayed in the 3D View window. The window 
is used for preparing and previewing a view that can be exported as a 2D CGM image. There are two types 
of image projection available for the 2D Preview window; orthographic and perspective.  
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• Choose the desired moment of 3D procedure by dragging the time slider on the Time Ruler of the 
Procedure Editor. 

• Choose the viewpoint of the outline graphics by navigating in the 3D View window. 

• If necessary, choose the perspective view for the outline image. To do this, on the View menu, click 
Perspective 2D Preview. 

• Once the outline graphics have been prepared, generate the outline image. To do this, on the View 
menu, click Create Outline Image. 

• In the Create Outline Image dialog box, type the image name and description, and then click OK. 

If necessary, preview and/or edit the ready-made outline images. To do this, on the View menu, click Edit 
Outline Images. Please note that editing outline images is done by Arbortext IsoView which should be 

installed separately. The created 2D image can be viewed with the  2D Graphics command.  

See VME/VTE help system for other operations on editing 3D Scene (section: Working with Outline Images). 

4.5. Publishing 3D Procedure 

Once the 3D procedure has been completed and the preview is satisfactory, publish the procedure using the 
Publish command in the VME or VTE application.  

NOTES:  

• The appearance and visualization mode of the published procedure is defined by the specification 
used. The appearance and the mode can be edited using a set of options in the Publish Options dialog 
box (Tools > Options > Publish). See section 6 for more details about specifications.  

• Previewing can be done by clicking  Preview on the Standard toolbar.  

 

5. Basics of Creating Training (RapidLearning Only)  
When creating training, the author reuses animations and actions created in the Procedure Editor. The 
Scenario Editor provides the functionality to create training scenarios. This section gives recommendations 
for creating training.  

1. Open a project by choosing any training specification (its name contains the training key word).   

2. In the Procedure Editor, design the structure of 3D procedure and create animations and actions.  

3. Create a scenario for the training.  

4. Add parts to the Parts List  

5. Add viewpoints to the training scenario.  

6. Save and publish the project. 
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5.1. Opening a project with VTE 

When opening a training project for the first time, a training specification should be selected in the Select 
Specification dialog box. If, for example, you have S1000D document of any maintenance procedure, choose 
S1000D Issue 2.3 Training. This allows you to automatically create the structure of the 3D procedure in the 
Procedure Editor and the template of the training scenario from the existing 3D procedure. Otherwise, you 
can choose Generic Training.   

5.2. Creating animations with VTE 

The procedure of creating animations is similar to that of VME application. The only difference is the Switch 
element in the structure. The Switch element allows alternative actions to be added to the procedure. In other 
words, the author of the training can create the training procedure in such a way that the trainee will see 
different animations, depending of the parameters the trainee enters. 

Procedure 

To add a New Switch: 

1. In the Action section of Procedure Editor, click Subtask, Step or Action that you want to create a new 
Switch element before.  

2. Click the  New Switch on the Procedure Editor Toolbar.  

3. In the Edit Group dialog that appears, type in the descriptive name of the Switch in the Description box. If 
you want to have the Switch element on the same hierarchy level as the subtask, make sure that Task is 
selected in the "Child of" list box and click OK. If you want to have the Switch element under the subtask 
group, choose the corresponding subtask name in the "Child of" list.  

5.3. Creating a scenario from existing 3D procedure 

The structure of a training scenario can be generated from a completed procedure.  

Procedure 

To generate a structure of training scenario from 3D procedure: 

1. Open the Scenario Editor tabbed page by clicking the Scenario Editor tab.  

2. On the Scenario menu, click Generate Scenario from Procedure.  

5.4. Using scenario elements 

Whenever the structure of training scenario is built, the author needs to add and modify scenario elements in 
the training scenario. There are three scenario elements: Operation, Request and Alert. The Operation 
element is used to set the task for the trainee (expected activity) and to specify the response of the training 
system when completed. The Request elements are used to request information from the trainee. The Alert 
elements are components that display a pop-up text message in the training.  

The most frequently used element is the Operation element. The Operation elements are added to the 
training scenario to ask the trainee to locate and select objects or parts in the 3D window in the specified 
order. Elements are added to the scenario using the context sensitive commands and appear in the Scenario 
Editor.  
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Procedure 

To add a new Operation element: 

1. In the Scenario Editor, click <add element>  

2. Select Operation, and then All items or Any of items.  

3. Click Browse, and then choose the object(s) you want. Click OK.  

4. If you want to add objects to the Operation element, click <add item> in the Scenario Editor and choose 
the object from the list.  

5. To type the text message, use the insertion point as shown on the following figure: 
  

6. If needed, add a question by using <add question>.  

7. To specify the reaction of the training system in the case of the correct trainee action, use <add 
animation>, <add message>.  

8. To specify parameters for conditional jumps, use <set parameter>.  

 

To add a new Request element: 

1. Make sure you have a scenario parameter or add a new one.  

2. In the Scenario Editor, click <add element>  

3. Select Request, type in the explanatory text in the Prompting box and in the Parameter list click the 
parameter of your choice.  

4. Click OK.  

 

To add a new Alert element: 

1. In the Scenario Editor, click <add element>  

2. Select Alert, and one of the notifications you want: Note, Warning, and Caution.  

3. Type a description of the alert message.  

4. Click OK  

See VTE help system for other information on editing training scenario (section: Creating Trainings). 

5.5. Creating training scenario from the scratch 

If required, a training scenario can be created manually by the author. 

1. Open the Scenario Editor tabbed page by clicking the Scenario Editor tab. 

2. In the Scenario Editor, click Add scenario to the project. 

3. To create the scenario of the training, you can give commands that are underlined control words. For 
example, if you would like to make a step in the training, you would click <add step>. Also there are 
command parameters that are underlined fields. Click on the underlined text to specify a new value.  
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4. Within the steps, add the required scenario elements: Operation, Request, and Alert. To add a new 
scenario element in the Scenario Editor, under the group item click <add element>. 

See VTE help system for other information on editing training scenario (section: Creating Trainings). 

5.6. Publishing Training 

Save and publish the finished version of your project. The Publish command from the File menu generates 
the training files. Please note that the default folder to save training is specified by the currently activated 
working area. The output folder contains both training and SCORM compliant training as a package of 
SCORM 2004. 

NOTES:  

• The appearance of the training can be edited using a set of options in the Publish Options dialog box 
(Tools > Options > Publish).  

• Previewing can be done by clicking  Preview on the Standard toolbar.  

 

6. Working with Specifications Components 
The application uses a set of components for authoring 3D enabled document in accordance with various 
information standards (S1000D Training and S1000D Procedure).  

Each specification component (specification) is designed for a particular information standard and defines the 
following: 

Set of metadata fields required in accordance with the standard.  

Set of declarations that describe the training/procedure appearance (for example, actions names, scenario 
structure, action default parameters and so on).  

Set of additional software components that allow the training/procedure authoring in accordance with the 
standard.  

Set of additional software components that allow publishing a project in formats required by the standard (for 
example, S1000D Issue 2.3 Training XML or S1000D Issue 2.3 Procedure XML) or additional formats 
requested by a customer.  

Set of resource files (for example, images, styles, scripts) that defines appearance and functionality of the 
resultant HTML based document.  

Note: 

• Application can support one specification at a time.  

• Each project saved by the application contains information about the specification used for creating 
such project.  

• If the required specification component is not installed on your computer, the project cannot be opened.  

• If the project specification is incompatible with the application, the project can be opened only using the 
Open As command.  
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6.1. Choosing Specifications  

It is possible to change the specification used by a project. To do this, use the Open As command in the 
Open Project dialog box. In some cases, a project will have information that is not compatible with a 
specification and the project specific data will be lost. 

Use the Open As command: 

• If the required specification component of the project is not installed on the computer. 

• If the specification component of the project to be opened is incompatible with VME/VTE. This allows 
reusing the data of a project created with one specification to create a new project in accordance with 
another specification.  

Procedure 

To choose a specification for an existing project: 

• On the File menu, click Open Project. 
The Open Project dialog box appears.  

• In the Open Project dialog box, click the name of the project for which a new specification to be 
chosen, and then click Open As. 
 

    

• The Select Specification dialog box appears. 

• In the Select Specification dialog box, choose the required specification, by clicking its name in the 
Name column.  
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• Click OK to save the choice and close the dialog box.  

6.2. Opening a Project Created with incompatible Specification  

For opening a project created with incompatible specification, it is recommended that the user should create 
a new working area for such a project. 

Procedure 

To open a project created with VME/VTE incompatible specification: 

• Export the project from its working area (see 7.2 for more details). 

• In the application, create a new working area for a project created with incompatible specification 
(Tools > Options > Select Configuration > New button). 

• Import the project to the new working area (see 7.2 for more details). 

6.3. Specification Details 

Currently, the VME and VTE use the following specification components for 3D procedure and training 
correspondingly: 

• S1000D Issue 2.3 Procedure  

• Generic Procedure 

• S1000D Issue 2.3 Training  

• Generic Training 

S1000D Issue 2.3 is a part of international specification for the procurement and production of technical 
publications.  

Generic is a specification designed for wide range of users to create simple 3D enabled documents. 

• The appearance and visualization mode of the resultant document is defined by the specification 
component used. The appearance and the mode can be edited using a set of options in the Publish 
Options dialog box (Tools > Options > Publish). In general, the options allow setting the appearance 
of 3D/2D window, document format and choosing a mode for visualizing the graphics. The detailed 
description of publish options for each specification component is available by clicking the Help button 
in the Publish Options dialog box. 
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7. Useful Additional Operations  

7.1. Configure VME or VTE 

With VMA you can specify and use several working folders for different groups of projects. This describes the 
mechanism that the application provides for easy switching from one working environment to another. 

• To configure the program to work with the existing working folders: 

• Click Tools, point to Options and click Select Configuration. In the Select Configuration dialog box, 
choose the name of working area by clicking it. Click OK.  

7.2. Exchange projects between the illustrators 

This section describes the mechanism that the VME or VTE application provides for exchanging data. 

Exporting project: 

• Start the applications and select the working area that contains the project(s) that you wish to export. 

• On the Tools menu, click Manage Projects. 

• Select the project you want to export from the Project list on the left and then click Export. Please note 
that you can select all projects by clicking Projects.  

• Specify the location where you want to save the selected project(s) in the Save in field. 

• In File name, type a name for the project archive (VMP file), and then click Save. 

• Click OK to close the Manage Projects dialog box.  

 

Importing project: 

• Start VTE (if you import the project on another computer) and select the working project to contain the 
imported project(s).  

• On the Tools menu, click Manage Projects. 

• Click Projects in the List of projects and then click Import. 

• In the Import Project dialog box, locate and open the folder containing the project archive (VMP file). 

• Select the project archive and then click Open. 

• If the project archive contains several projects, the Import Multiple Projects dialog appears. In the 
Projects list, select project(s) you want to import. Click OK. Please note that, by default, all projects in 
the Projects list appear selected.  

• Click OK to close the Manage Projects dialog box. 
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